zonArt / mktk-list-converter

Python script to convert lists coming from sites like http://urlblacklist.com/ to .rsc files for RouterOS (Mikrotik)

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

mktk-list-converter

Python script to convert lists coming from sites like http://urlblacklist.com/ to .rsc files for RouterOS (Mikrotik)

There are two domain lists in the "sample" folder, one can test the following:

python3 tik_conv.py -l sample/whitelist -a

Should create result.rsc which looks like this:

# Generated by mktk-list-converter
:put "Importing the web-proxy configuration";
/ip proxy access
add action=allow disabled=no dst-host=*google.com
add action=allow disabled=no dst-host=*youtube.com
add action=allow disabled=no dst-host=*facebook.com
add action=allow disabled=no dst-host=*github.com
:put "Import finished successfully";

python3 tik_conv.py -l sample/blacklist -d

Should create result.rsc which looks like this:

# Generated by mktk-list-converter
:put "Importing the web-proxy configuration";
/ip proxy access
add action=deny disabled=no dst-host=*evilsite.com
add action=deny disabled=no dst-host=*malware.com
add action=deny disabled=no dst-host=*piracy.com
add action=deny disabled=no dst-host=*porn.com
:put "Import finished successfully";

About

Python script to convert lists coming from sites like http://urlblacklist.com/ to .rsc files for RouterOS (Mikrotik)

License:GNU General Public License v3.0


Languages

Language:Python 100.0%