kairat1115 / kickstart.nix

Kickstart your Nix environment.

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

kickstart.nix

Kickstart your Nix environment.

Table of Contents

Prerequisites

  • Familiarity with terminal commands.
  • An account on GitHub for forking the repository.
  • GitHub CLI (gh) installed for some commands.

Initial Setup

Choose the appropriate setup instructions based on your operating system.

macOS

  1. Install nixpkgs with official script:
sh <(curl -L https://nixos.org/nix/install)
  1. Install nix-darwin with official steps:
nix-build https://github.com/LnL7/nix-darwin/archive/master.tar.gz -A installer
./result/bin/darwin-installer
  1. Answer the following with y to edit your default configuration.nix file:
Would you like to edit the default configuration.nix before starting? [y/n] y
  1. Add the following to configuration.nix to enable nix-command and flakes features:
nix.settings.experimental-features = [ "nix-command" "flakes" ];
  1. Answer the following with y to setup <darwin> in nix-channel (though it won't be used):
Would you like to manage <darwin> with nix-channel? [y/n] y
  1. Fork this repository to create your own flake kickstart.

Note This can be done in the Github UI at: https://github.com/ALT-F4-LLC/kickstart.nix

gh repo fork ALT-F4-LLC/kickstart.nix
  1. Clone your new fork locally to customize:

Note If the following command does not work revist steps 1 & 2.

nix run nixpkgs#git clone https://github.com/<username>/kickstart.nix
  1. Update the following value(s) in flake.nix configuration:
let
    username = "<insert-username>"; # replace
in
  1. Switch to kickstart.nix environment for your system with flake configuration:
darwin-rebuild switch --flake ".#darwin-aarch64" # for M1/M2 Chipsets
darwin-rebuild switch --flake ".#darwin-x86_64" # for Intel Chipsets

NixOS

  1. Add the following to /etc/nixos/configuration.nix to enable nix-command and flakes features:
nix.settings.experimental-features = [ "nix-command" "flakes" ];
  1. Update you system to reflect the changes:
nixos-rebuild switch
  1. Fork this repository to create your own flake kickstart.

Note This can be done in the Github UI at: https://github.com/ALT-F4-LLC/kickstart.nix

gh repo fork ALT-F4-LLC/kickstart.nix
  1. Clone your new fork locally to customize:

Note If the following command does not work revist steps 1 & 2.

nix run nixpkgs#git clone https://github.com/<username>/kickstart.nix
  1. Update the following value(s) in flake.nix configuration:
let
    username = "<insert-username>"; # replace
in
  1. Switch to kickstart.nix environment for your system with flake configuration:
nixos-rebuild switch --flake ".#nixos-aarch64" # for ARM Chipsets
nixos-rebuild switch --flake ".#nixos-x86_64" # for Intel Chipsets

Personalizing Your Environment

You can further tailor your Nix environment through configurations.

Darwin

  • nix-darwin system options exist in ./system/darwin.nix
  • home-manager system options exist in ./system/darwin.nix

NixOS

Important The default user password can be found and updated in ./system/nixos.nix.

  • nixos system hardware options exist in ./system/nixos-hardware-configuration.nix
  • nixos system options exist in ./system/nixos.nix
  • home-manager system options exist in ./module/home-manager.nix

Shared

  • nix system options exist in ./module/configuration.nix
  • home-manager user options exist in ./module/home-manager.nix

About

Kickstart your Nix environment.

License:Apache License 2.0


Languages

Language:Nix 100.0%