hellwolf / haskell-tooling.nix

Nix flake for installing haskell tooling.

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Yet Another Nix Flake For Installing Haskell Tooling

Examples

{
  inputs = {
    flake-utils.url = "github:numtide/flake-utils";
    haskell-tooling.url = "github:hellwolf/haskell-tooling.nix";
  };

  outputs = { nixpkgs, flake-utils, haskell-tooling, ... }:
  (flake-utils.lib.eachDefaultSystem (system:
    let
      pkgs = import nixpkgs { inherit system; };
    in {
      devShells.default = pkgs.mkShell {
        buildInputs = haskell-tooling.lib.install pkgs ["ghc96" "ghc94+hls" "ghc92+hls"];
      };
    }));
}

About

Nix flake for installing haskell tooling.

License:MIT License


Languages

Language:Nix 100.0%