antfu / vite-plugin-inspect

Inspect the intermediate state of Vite plugins

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

vite-plugin-inspect

NPM version

Inspect the intermediate state of Vite plugins. Useful for debugging and authoring plugins.

Install

npm i -D vite-plugin-inspect

Since vite-plugin-inspect@v0.5.0, Vite v2.9 or above is required.

Add plugin to your vite.config.ts:

// vite.config.ts
import Inspect from 'vite-plugin-inspect'

export default {
  plugins: [
    Inspect(), // only applies in dev mode
  ],
}

Then visit localhost:3000/__inspect/ to inspect the modules.

Sponsors

License

MIT License © 2021 Anthony Fu

ezoic increase your site revenue

About

Inspect the intermediate state of Vite plugins

License:MIT License


Languages

Language:Vue 49.2%Language:TypeScript 42.7%Language:CSS 6.1%Language:HTML 2.0%