NuxNuxLi / EK-7688AMx.OW1407

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

EK-7688AMx.OW1407

How to build the firmware for EK-7688AMx?

  1. Install prerequisite packages

  2. Update the feed information for all packages and install all packages

      ./scripts/feeds update -a
      ./scripts/feeds install -a
    
  3. Choose default config -- make defconfig

  4. Select options for EK-7688AMx -- cp EK-7688AMx.OW1407 .config

  5. Make a new firmware -- make V=s

  6. Get a new firmware under bin/ramips/xxx-sysupgrade.bin

How to setup AP-Client mode?

  1. Rewrite /etc/config/network -- vi /etc/config/network (ps:look for the apcli0's mac ifconfig apcli0 up ifconfig)

    config interface 'lan'
    	option ifname 'eth0.1'
    	option force_link '1'
    	option type 'bridge'
    	option proto 'static'
    	option ipaddr '192.168.1.1'
    	option netmask '255.255.255.0'
    	option ip6assign '60'
    	option macaddr '9C:65:F9:1D:80:AF'
    
    config interface 'wan'
    	+++option ifname 'apcli0'
    	option proto 'dhcp'
    	+++option macaddr '9E:65:F9:0D:81:28'
    
  2. Rewrite /etc/config/wireless -- vi /etc/cnfig/wireless

    	+++option channel  3  (ps: the same as RootAP's)
    	option auotch   2
    
    config wifi-iface
    	option device   mt7628
    	option ifname   ra0
    	option network  lan
    	option mode     ap
    	option ssid     mt7628-80AF  
    	option encryption psk2
    	option key      12345678
    	+++option ApCliEnable '1'                        
    	+++option ApCliSsid 'RootAP_SSID' (RootAP's SSID)
    	+++option ApCliBssid 'xx:xx:xx:xx:xx:xx'  (RootAP's BSSID)
    	+++option ApCliAuthMode 'WPA2PSK'  (RootAP's Auth.)
    	+++option ApCliEncrypType 'AES'  (RootAP's Encryp.)
    	+++option ApCliWPAPSK 'RootAP_PW' (RootAP's password)
    
  3. restart network -- /etc/init.d/network restart

About

License:GNU General Public License v2.0


Languages

Language:C 66.1%Language:Lua 9.6%Language:Makefile 8.3%Language:HTML 4.0%Language:Shell 4.0%Language:Objective-C 2.0%Language:Perl 1.8%Language:C++ 1.0%Language:Assembly 0.9%Language:M4 0.4%Language:CSS 0.4%Language:JavaScript 0.3%Language:Java 0.3%Language:C# 0.3%Language:Visual Basic 0.2%Language:Yacc 0.2%Language:Max 0.1%Language:Lex 0.1%Language:Python 0.1%Language:Awk 0.0%Language:CMake 0.0%Language:ApacheConf 0.0%