yonaskolb / SwagGen

OpenAPI/Swagger 3.0 Parser and Swift code generator

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Issue with swagger_2 Xcode 13

danya61 opened this issue · comments

Hello!
I'm using 3.02 version of SwagGen, Xcode 13.

Trying to install:

git clone -b swagger_2 https://github.com/yonaskolb/SwagGen.git
cd SwagGen
make install

the output is:

swift build --disable-sandbox -c release -Xswiftc -static-stdlib
Updating https://github.com/yonaskolb/JSONUtilities.git
Updating https://github.com/onevcat/Rainbow.git
Updating https://github.com/kylef/PathKit.git
Updated https://github.com/onevcat/Rainbow.git (0.45s)
Updated https://github.com/kylef/PathKit.git (0.45s)
Updated https://github.com/yonaskolb/JSONUtilities.git (0.45s)
Updating https://github.com/jpsim/Yams.git
Updating https://github.com/yonaskolb/Stencil.git
Updating https://github.com/jakeheis/SwiftCLI
Updated https://github.com/yonaskolb/Stencil.git (0.50s)
Updated https://github.com/jpsim/Yams.git (0.50s)
Updated https://github.com/jakeheis/SwiftCLI (0.50s)
Updating https://github.com/kylef/Spectre.git
Updated https://github.com/kylef/Spectre.git (0.37s)
Computing version for https://github.com/onevcat/Rainbow.git
Computed https://github.com/onevcat/Rainbow.git at 3.1.4 (0.03s)
Computing version for https://github.com/kylef/Spectre.git
error: the manifest is missing a Swift tools version specification; consider prepending to the manifest '// swift-tools-version:5.5.0' to specify the current Swift toolchain version as the lowest Swift version supported by the project; if such a specification already exists, consider moving it to the top of the manifest, or prepending it with '//' to help Swift Package Manager find it
make: *** [build] Error 1

Any suggestion how to solve it? Thanks in advance

ezoic increase your site revenue