yonaskolb / SwagGen

OpenAPI/Swagger 3.0 Parser and Swift code generator

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Swift 5 Support & Interchangeable Network Layer

spprichard opened this issue · comments

Hi,

This is less an issue and more a series of questions.

  1. Is there a plan to have Swift 5 support? I might be missing something here, but I don't see anything in the docs talking about this project generating swift 5.0 code. Would this be possible? What would the priority of this be?

  2. Looking at the templates, it appears that the networking package defaults to Alamofire. What would the work be in making that configurable? For example, what if I wanted to use a networking package that was compatible with Linux (Swift-Nio, etc)? What is the difficulty on making this change? What would the priority of this change be? How important do you deem this change to be?

I look forward to your responses,
Cheers

ezoic increase your site revenue