salesforce / CodeGen

CodeGen is an open-source model for program synthesis. Trained on TPU-v4. Competitive with OpenAI Codex.

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Problems with torch

tb852 opened this issue · comments

When trying to install CodeGen locally I run "pip3 install -r requirements.txt" and get the following error:
Looking in links: https://download.pytorch.org/whl/torch_stable.html
ERROR: Could not find a version that satisfies the requirement torch==1.9.0+cu111 (from versions: 1.11.0, 1.11.0+cpu, 1.11.0+cu113, 1.11.0+cu115, 1.12.0, 1.12.0+cpu, 1.12.0+cu113, 1.12.0+cu116, 1.12.1, 1.12.1+cpu, 1.12.1+cu113, 1.12.1+cu116, 1.13.0, 1.13.0+cpu, 1.13.0+cu116, 1.13.0+cu117)
ERROR: No matching distribution found for torch==1.9.0+cu111

I have Windows 10, Intel(R) UHD Graphics GPU and I run "pip3 install --upgrade pip setuptools successfully". Any ideas what could I do?

The CodeGen model has been integrated with HuggingFace's transformers library, so that the code in this repository is not needed.

Here an example of how to sample with transformers:
https://colab.research.google.com/drive/11YU00W-JLNXn-3YckJGOSxFf_TQfCXYr?usp=sharing

Does this help?

pip install pillow
pip install torch==1.9.0+cu111 torchvision==0.10.0+cu111 torchaudio==0.9.0 -f https://download.pytorch.org/whl/torch_stable.html

Reference: https://pytorch.org/get-started/previous-versions/
or download whl from https://download.pytorch.org/whl/cu111/torch-1.9.0%2Bcu111-cp38-cp38-win_amd64.whl and install:
pip install torch-1.9.0+cu111-cp38-cp38-win_amd64.whl.whl
visit https://github.com/git-cloner/codegen for details