rmosolgo / graphql-ruby

Ruby implementation of GraphQL

Home Page:http://graphql-ruby.org

graphql-ruby's ContributorsJulAugSepOctNovDecJanFebMarAprMayJunJulSunMonTueWedThuFriSat

graphql graphql-ruby

CI Suite Gem Version

A Ruby implementation of GraphQL.

Installation

Install from RubyGems by adding it to your Gemfile, then bundling.

# Gemfile
gem 'graphql'
$ bundle install

Getting Started

$ rails generate graphql:install

After this, you may need to run bundle install again, as by default graphiql-rails is added on installation.

Or, see "Getting Started".

Upgrade

I also sell GraphQL::Pro which provides several features on top of the GraphQL runtime, including Pundit authorization, CanCan authorization, Pusher-based subscriptions and persisted queries. Besides that, Pro customers get email support and an opportunity to support graphql-ruby's development!

Goals

  • Implement the GraphQL spec & support a Relay front end
  • Provide idiomatic, plain-Ruby API with similarities to reference implementation where possible
  • Support Ruby on Rails and Relay

Getting Involved

About

Ruby implementation of GraphQL

http://graphql-ruby.org

License:MIT License


Languages

Language:Ruby 93.2%Language:TypeScript 4.0%Language:HTML 1.0%Language:Yacc 0.8%Language:SCSS 0.4%Language:JavaScript 0.3%Language:Ragel 0.3%