nodemcu / nodemcu-flasher

A firmware Flash tool for nodemcu

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

FLASH DOES NOT WORK!

eholl opened this issue · comments

commented

When i press flash it does no download anything the bar does not even come up please help me

same ....not flashing

I have been working for over 12 hours trying to flash this. I have tried with Windows, Kali, Debian, and OS X. ONE time it was successful, but then bricked (again) after loading a payload and rebooting the device. This is becoming mentally exhausting. I have performed the steps so many times, I've memorized them. I upload, the export, then flash, then upload again. Device never resets itself... ANY help would be appreciated.

commented

Hi Guys.. For future posterity... I got it working. I've got a clone NodeMCU mini and was fighting with the same issue. It would just flash the blue LED and nothing would happen. Here's what worked for me. 1) make sure defaults are selected under the Advanced menu. Then before plugging the Node into USB, I held down the Flash button, plugged it into USB cable, released the flash button, then clicked the flash. Only then did it ID the MAC addresses and start flashing. Now I just need to verify if it works.. Not done this before...

Following-up on this as I can now upload sketches using Arduino as well - so the above worked. My case may be unique but I noticed that although mine has USB on-board and should auto-flash during Arduino FW load, it doesn't. Each time I have to unplug the USB cable, hold the Flash button, plug in the USB, let go the flash button, then upload the sketch. Also it can only do it at 115200 Baud. I think this is unique, but something to try in event you are having troubles.

ezoic increase your site revenue