google / zx

A tool for writing better scripts

Home Page:https://npmjs.com/package/zx

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Failed to install on node 16

passos opened this issue · comments

Expected Behavior

can be installed on NodeJS 16

Actual Behavior

One of the dependency failed to install because of NodeJS version.

Steps to Reproduce the Problem

$ node --version
v16.14.0

$ yarn --version
1.22.15

$ yarn global add zx
yarn global v1.22.15
[1/4] 🔍  Resolving packages...
[2/4] 🚚  Fetching packages...
error create-strapi-app@3.3.4: The engine "node" is incompatible with this module. Expected version ">=10.16.0 <=14.x.x". Got "16.14.0"
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/global for documentation about this command.

Specifications

  • Version: 11.6.1
  • Platform: maxOS
ezoic increase your site revenue