codeagencybe / vips-image-editor

High performance WordPress image processing with VIPS

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

VIPS Image Editor

Build Status Packagist

High performance WordPress image processing with VIPS.

Requirements

  • PHP 7 or later
  • vips package installed on your Linux system
  • vips PHP extension

Installation

  1. Install vips on your system. On Ubuntu, this can be done using apt install libvips-dev
  2. Install vips extension using pecl, this can be done with command pecl install vips
  3. Enable PHP extension, this is usually done by adding the line extension=vips.so to php.ini
  4. Download the latest plugin version from the releases tab
  5. Extract the plugin under wp-content/plugins
  6. Enable the plugin in WordPress admin interface

About

High performance WordPress image processing with VIPS


Languages

Language:PHP 97.6%Language:Dockerfile 2.4%