capeprivacy / cape-python

Collaborate on privacy-preserving policy for data science projects in Pandas and Apache Spark

Home Page:https://docs.capeprivacy.com

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Required pandas version 1.0.3. conflicts with other packages

shukkkur opened this issue · comments

Describe the bug
On some machines pip install cape-privacy doesn't work and it says conflicting versions of pandas. Whereas, on others with pandas==1.0.3 DatePerturbation gives an error
ImportError: cannot import name 'values_from_object' from 'pandas._libs.lib' (/usr/local/lib/python3.7/dist-packages/pandas/_libs/lib.cpython-37m-x86_64-linux-gnu.so)

After uninstalling pandas 1.0.3 and installing the newest version of pandas, the method work

Screenshots
image

Desktop (please complete the following information):

  • OS: [Linux]
  • OS Version [21.04]
  • Python 3.9.5
  • Installed pip packages

Please loosen up pandas and numpy versions in setup.py and requirements.txt @justin1121
I am using this package for my project.

If you also have installation problem, first
pip install cape-privacy==0.3.0 --no-deps
Then, copy the requirements.txt and change numpy and pandas versions in there. After, install the requirements.
pip install -r requirements.txt