capeprivacy / cape-python

Collaborate on privacy-preserving policy for data science projects in Pandas and Apache Spark

Home Page:

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Pandas compatibility

VincentAntoine opened this issue · comments


I'd like to use cape-privacy in a project, however, said project runs pandas 1.2 which not compatible with cape-python's dependency constraint of pandas~=1.0.3.

As pandas 1.0 is now more than 1 year old, would it be possible to release a new version of cape-privacy without the version constraint on pandas (I'm assuming it works without changing anything to cape-python) ?

Hi @VincentAntoine thanks for letting us know. We'll take a look!

@gavinuhma Any Updates ?

Solution that worked for me:

  1. copied requirements.txt. Changed pandas & numpy versions in that file.
  2. pip install cape-privacy --no-deps. It will install cape-privacy but without installing the requirements.
  3. pip install -r requirements.txt. Now we just install our version of the required packages.