batfish / batfish

Batfish is a network configuration analysis tool that can find bugs and guarantee the correctness of (planned or current) network configurations. It enables network engineers to rapidly and safely evolve their network, without fear of outages or security breaches.

Home Page:http://www.batfish.org

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Can't Batfish analyze such EVPN configurations?Which Cisco series EVPN configuration network Batfish supports for analysis ?

LiuXinZhe21 opened this issue · comments

I cannot obtain the correct VXLAN results when analyzing such EVPN configurations using Batfish。

I also want to ask which Cisco series EVPN configuration network Batfish supports for analysis!!!

Can you give me an example?Thank you!

!
hostname VTEP1
!
vrf definition green
rd 103:2
!
address-family ipv4
route-target export 103:2
route-target import 104:2
route-target export 103:2 stitching
route-target import 104:2 stitching
exit-address-family
!
!
ip routing
ip multicast-routing
!
!
l2vpn evpn
replication-type static
router-id Loopback0
default-gateway advertise
!
l2vpn evpn instance 1 vlan-based
encapsulation vxlan
!
l2vpn evpn instance 2 vlan-based
encapsulation vxlan
!
!
system mtu 9150
!
vlan configuration 200
member vni 5000
vlan configuration 201
member evpn-instance 1 vni 6000
vlan configuration 202
member evpn-instance 2 vni 7000
!
!
interface Loopback0
ip address 10.1.1.10 255.255.255.255
ip pim sparse-mode
!
interface Loopback13
description demo only (for rt5 distribution)
vrf forwarding green
ip address 10.1.13.13 255.255.255.0
!
interface GigabitEthernet1/0/1
description access-facing-interface
switchport trunk allowed vlan 201,202
switchport mode trunk
!
!
interface GigabitEthernet1/0/29
description core-underlay-interface
no switchport
ip address 172.16.1.29 255.255.255.0
ip pim sparse-mode
!
!
interface Vlan200
description core svi for l3vni
vrf forwarding green
ip unnumbered Loopback0
ipv6 enable
no autostate
!
interface Vlan201
description vni 6000 default-gateway
vrf forwarding green
ip address 192.168.1.201 255.255.255.0
!
interface Vlan202
description vni 7000 default-gateway
vrf forwarding green
ip address 192.168.2.202 255.255.255.0
!
!
interface nve10
no ip address
source-interface Loopback0
host-reachability protocol bgp
member vni 6000 mcast-group 232.1.1.1
member vni 5000 vrf green
member vni 7000 mcast-group 232.1.1.1
!
router ospf 1
router-id 10.1.1.10
network 10.1.1.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 0
!
router bgp 10
bgp router-id interface Loopback0
bgp log-neighbor-changes
bgp update-delay 1
no bgp default ipv4-unicast
neighbor 10.2.2.20 remote-as 10
neighbor 10.2.2.20 update-source Loopback0
!
address-family ipv4
exit-address-family
!
address-family l2vpn evpn
neighbor 10.2.2.20 activate
neighbor 10.2.2.20 send-community both
exit-address-family
!
address-family ipv4 vrf green
advertise l2vpn evpn
redistribute connected
redistribute static
exit-address-family
!
!
ip pim rp-address 10.1.1.10
!
end

and config**!
hostname VTEP2
!
vrf definition green
rd 104:2
!
address-family ipv4
route-target export 104:2
route-target import 103:2
route-target export 104:2 stitching
route-target import 103:2 stitching
exit-address-family
!
!
ip routing
ip multicast-routing
!
!
l2vpn evpn
replication-type static
router-id Loopback0
default-gateway advertise
!
l2vpn evpn instance 1 vlan-based
encapsulation vxlan
!
l2vpn evpn instance 2 vlan-based
encapsulation vxlan
!
!
system mtu 9150
!
vlan configuration 200
member vni 5000
vlan configuration 201
member evpn-instance 1 vni 6000
vlan configuration 202
member evpn-instance 2 vni 7000
!
!
interface Loopback0
ip address 10.2.2.20 255.255.255.255
ip pim sparse-mode
!
interface Loopback14
description demo only (for rt5 distribution)
vrf forwarding green
ip address 10.1.14.14 255.255.255.0
!
interface GigabitEthernet1/0/1
description access-facing-interface
switchport trunk allowed vlan 201,202
switchport mode trunk
!
!
interface GigabitEthernet1/0/30
description core-underlay-interface
no switchport
ip address 172.16.1.30 255.255.255.0
ip pim sparse-mode
!
!
interface Vlan200
description core svi for l3vni
vrf forwarding green
ip unnumbered Loopback0
no autostate
!
interface Vlan201
description vni 6000 default-gateway
vrf forwarding green
ip address 192.168.1.201 255.255.255.0
!
interface Vlan202
description vni 7000 default-gateway
vrf forwarding green
ip address 192.168.2.202 255.255.255.0
!
!
interface nve10
no ip address
source-interface Loopback0
host-reachability protocol bgp
member vni 6000 mcast-group 232.1.1.1
member vni 7000 mcast-group 232.1.1.1
member vni 5000 vrf green
!
router ospf 1
router-id 10.2.2.20
network 10.2.2.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 0
!
router bgp 10
bgp router-id interface Loopback0
bgp log-neighbor-changes
bgp update-delay 1
no bgp default ipv4-unicast
neighbor 10.1.1.10 remote-as 10
neighbor 10.1.1.10 update-source Loopback0
!
address-family ipv4
exit-address-family
!
address-family l2vpn evpn
neighbor 10.1.1.10 activate
neighbor 10.1.1.10 send-community both
exit-address-family
!
address-family ipv4 vrf green
advertise l2vpn evpn
redistribute connected
redistribute static
exit-address-family
!
!
ip pim rp-address 10.1.1.10
!
end**